Compatibility and System Requirements

Inspector is compatible with the following version of SCENE:
Scene 5.2.5+

System Requirements:
3rd Party Installer